Illuminate / Censum as a Service minimum requirements

 In

NOTE: Censum as a Service is an illuminate module which can be run as a standalone service.  References to Illuminate can be substituted for Censum as a Service if you’re only using that module.

The minimum requirements to run a Illuminate Daemon are:

  • Linux Kernel 2.6.0+ (or Solaris 10+ for Censum as a Service)
  • OpenJDK or Sun/Oracle JDK 1.7.0+

We recommend running the very latest version of OpenJDK or Sun/Oracle’s JDK.

The configuration required to run a Illuminate Daemon are:

  • /proc needs to be mounted
  • Illuminate Daemon needs to start as the same user as the Java/JVM application you are monitoring.
Recent Posts